Loud rubber squeak from bushings - RangerForums.net - Polaris Ranger Forum
Full Size Ranger Discussion Talk about the full-size ranger

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 8 Old 01-15-2009, 08:33 PM Thread Starter
Couch Potato
 
amccaul's Avatar
 
Join Date: Jan 2009
Posts: 9
Loud rubber squeak from bushings

I have only about 15 hours on 2009 Ranger and this last weekend noticed that the bushings seem to squeak horribly as the frame goes up and down. Is this something the dealer forgot to lube? Can I lube these bushings and if so what should I use? Thanks!
amccaul is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 01-16-2009, 01:27 AM
Miller Time
 
Code Blue's Avatar
 
Join Date: Dec 2007
Posts: 635
Re: Loud rubber squeak from bushings

I've had two Rangers and now have two Razors, add that to the plethora of other ATVs and I must admit that after running them through water they all make the loud squeak. If someone has a remedy I'm jumping in too..

Washington and no not that side of the state
Member# 5
Speed up you to can arrive DOA
Code Blue is offline  
post #3 of 8 Old 01-16-2009, 07:32 AM
Ripsaw
 
GRAZOR's Avatar
 
Join Date: Dec 2007
Posts: 1,250
Re: Loud rubber squeak from bushings

Mine does it after riding in the rain and then drying off. I use either WD-40 or Silicone spray like what I use on the car door weather stripping and it works fine.

Look over your machine and where ever the rubber bushings are pinched against metal or where metal goes through a rubber bushing is where you spray.

Gary

I thought about becoming a "Positive Thinker" but I was pretty sure it wouldn't work!
GRAZOR is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 01-16-2009, 08:23 AM
Turbo
 
Bigdog800efi's Avatar
 
Join Date: Dec 2007
Posts: 373
Re: Loud rubber squeak from bushings

Use a spray lubricant . At the very top of the strut there is a plastic bushing and that is normanlly the culprit. It is located at the between the top strut frame support and the spring cap.

Plays well with others
Bigdog800efi is offline  
post #5 of 8 Old 01-16-2009, 09:42 PM
Miller Time
 
Code Blue's Avatar
 
Join Date: Dec 2007
Posts: 635
Re: Loud rubber squeak from bushings

Good Idea guy's I'm all over that fix..

Washington and no not that side of the state
Member# 5
Speed up you to can arrive DOA
Code Blue is offline  
post #6 of 8 Old 01-17-2009, 07:20 PM
Pavement Ripper
 
nd4speed's Avatar
 
Join Date: Sep 2008
Posts: 22
Re: Loud rubber squeak from bushings

Install a Kenwood and TURN IT UP!!!!!
nd4speed is offline  
post #7 of 8 Old 01-18-2009, 01:27 PM
Supernova
 
caglezxj's Avatar
 
Join Date: Dec 2007
Posts: 2,273
Send a message via Yahoo to caglezxj
Re: Loud rubber squeak from bushings

Use white lithium grease. You can get it in a spray can and it is the best to use on those poly bushings .

caglezxj is offline  
post #8 of 8 Old 01-19-2009, 03:23 PM Thread Starter
Couch Potato
 
amccaul's Avatar
 
Join Date: Jan 2009
Posts: 9
Re: Loud rubber squeak from bushings

Thanks for all the suggestions...I will stop by the parts store today for the remedy. I am sure it is the water getting in there as I have a creek I must cross every day to check cattle. Thanks again.
amccaul is offline  
Reply

  Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Full Size Ranger Discussion

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
why is my ranger so loud? pjhruska North East Chapter 1 01-22-2010 06:21 AM
Rubber Down 1/2" Spring Spacers caglezxj For Sale 7 12-08-2008 10:53 PM
Man is this thing loud!!! Fike Mtn WV Full Size Ranger Discussion 5 11-25-2008 02:10 AM
sway bar bushings on front end T-BO Polaris RZR Forum Discussion 3 04-27-2008 08:42 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome