Polaris Ranger Forum - Header Left   Polaris Ranger Forum - Header Right

Need help - Rough running Ranger

This is a discussion on Need help - Rough running Ranger within the Full Size Ranger Discussion forums, part of the Polaris Ranger Forum category; I have an 06 XP & have been having some running problems with it & wanted to get input from the forum. When my Ranger ...

Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Full Size Ranger Discussion

Full Size Ranger Discussion Talk about the full-size ranger

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 07-28-2009, 01:16 PM   #1
Junior Member
 
7lazy77's Avatar
 
Join Date: May 2009
Posts: 3
Need help - Rough running Ranger

I have an 06 XP & have been having some running problems with it & wanted to get input from the forum. When my Ranger is cold, it starts & idles normol. BUT when it gets warmed up, it sputters on idle or even dies. The local Polaris dealer said the TPS (Throttle Position Sensor) needs replaced. Does this sound like it would help resolve the problem. I found one on ebay, are they easy to replace, or should it be done at the dealer?
I am also experiencing some rattling coming from the Ranger when I am in high rpm's. It sounds like it is coming from underneath, but I have looked around & not found anything that is loose. Is this common? Any input on what I could look at to see if I can fix the problem? THANKS for the help!
7lazy77 is offline   Reply With Quote
Remove Ads
Old 07-28-2009, 03:27 PM   #2
Senior Member
 
caglezxj's Avatar
 
Join Date: Dec 2007
Posts: 2,313
Send a message via Yahoo to caglezxj
Re: Need help - Rough running Ranger

Welcome to Polaris Ranger Forum!

The rattles.... They all do it. Sometimes it can be the Aluminum Exhaust shield vibrating on the exhaust. Just bend it back. Then it could also be the springs that hold the muffler on, but mine seemed tight and the shield was my issue. If it is out of warranty then I would get the sensor and install it myself. Just take your time, it is an easy change. And those sensor have been issues that cause that problem. Let us know what you figure out.

Josh
__________________
caglezxj is offline   Reply With Quote
Old 07-28-2009, 06:20 PM   #3
Member
 
carnivore's Avatar
 
Join Date: Jan 2008
Posts: 66
Re: Need help - Rough running Ranger

Josh is right, the rattles are pretty normal, and are usually something to do with a cracked or loose heat shield.
The TPS, if that is the problem is easy to change, but is real sensitive to adjustments. You have to back probe the yellow wire at the connector and connect a multimeter to it. You have to unhook the throttle cable, back off the air idle screw untill it doesnt touch the throttle arm (which in turn closes the butterfly), then adjust the TPS to .528 volts. Lock down the TPS, making sure it reains at .528, then turn the air idle screw while watching the multimeter until it reads .660 on 06 and 08s, and .710 on 05 and 07s. Then hook the throttle cable back up, being sure it has just enough slack that it doesnt pull on the throttle.
The bad news is sometimes those symptoms are caused by a bad Tbap sensor or damaged wiring to the Tbap. Both parts can cause simlar symptoms. Be sure to check the iwres right at the Tbap connector, they can break inside the plastic, so you have to lightly pull on them to see if they stretch.
__________________
Curt
Grand Ledge, MI
09 800 XP,[b]Dirty Dawg Performance 800 kit w/ported head,DDP cam,Bored throttle body,DDP clutch kit w/supertip weights,Boonedocker,DDP ECU, Ranger Pro Lift 2" forward a arms w/2" lift
carnivore is offline   Reply With Quote
Old 07-29-2009, 12:48 AM   #4
Junior Member
 
7lazy77's Avatar
 
Join Date: May 2009
Posts: 3
Re: Need help - Rough running Ranger

Thanks for your input! I'm NOT too mechanically inclined, so it may be in my best interest to just take it to the dealer & get bent over $$. Appreciate your help fellers!
7lazy77 is offline   Reply With Quote
Old 11-26-2009, 11:32 AM   #5
Junior Member
 
chadjones99's Avatar
 
Join Date: Oct 2008
Posts: 21
Re: Need help - Rough running Ranger

I just moved my TPS intill the machine ran better. but I think its eatting my fuel now
anyone know were to find a after market TPS ?
chadjones99 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Full Size Ranger Discussion


Search tags for this page
06 polaris ranger 700 xp throttle positioning sensor
,
2007 polaris ranger 700 sputtering low rpm tbap
,
how to adjust tps on polaris ranger 700 efi
,
how to replace the tps on a 2009 polaris ranger
,
poaris ranger 2008,700xp sputters and dies
,
polaris ranger 2009 700 efi throttle positioning sensor
,

polaris ranger running rough

,
polaris ranger running rough is it an octan problem
,
polaris ranger runs rough
,
polaris ranger throttle position sensor
,

polaris ranger tps problems

,
throttle position sensor 2008 polaris ranger 700
Click on a term to search for related topics.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ranger rough idle/sputters/dies azar5613 Full Size Ranger Discussion 4 06-29-2010 08:09 PM
2005 ranger 700EFI 6x6 wont stay running jsimmons33 General Discussion 2 03-06-2010 12:34 AM
2008 Ranger running rough nvwolfer Full Size Ranger Discussion 0 02-14-2010 03:31 PM
2005 Ranger 4x4 won't go into high while running rockyhyder Modified Tech Discussion 2 02-01-2009 08:38 PM
2004 Ranger 500 6x6 running rich nomekennedys Modified Tech Discussion 2 05-16-2008 06:21 PM


All times are GMT -5. The time now is 01:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.