Polaris Ranger Forum - Header Left   Polaris Ranger Forum - Header Right

ranger rough idle/sputters/dies

This is a discussion on ranger rough idle/sputters/dies within the Full Size Ranger Discussion forums, part of the Polaris Ranger Forum category; i realize this was perhaps posted before but here we go again. I have a 2007 ranger 500 efi. It sat for a few years ...

Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Full Size Ranger Discussion

Full Size Ranger Discussion Talk about the full-size ranger

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 06-26-2010, 01:53 AM   #1
Member
 
azar5613's Avatar
 
Join Date: May 2010
Location: Kearneysville, WV
Posts: 85
ranger rough idle/sputters/dies

i realize this was perhaps posted before but here we go again. I have a 2007 ranger 500 efi. It sat for a few years but has less than 60hrs on it. i fixed it up but has recently begun having issues. basically i start it up and starts idling high. it then beguns to sputter and eventually dies, sometimes backfires as well. i have a friend that is a gearhead and we have done the following: changed the oils and gas, checked the filters, took the carb apart and cleaned it along with the sensors... there might be a few more things but that just about covers it. at slightly above normal idle i can hear a small clicking sound coming from perhaps the bottom end but i have read that is normal. once i raise the throttle it all goes away; roughness, no miss from the bottom end... i have checked the sensor connectors and they are not burned. i have checked the wire harness and have not seen any opens or shorts. i wonder if something could have happened when taking the carb apart but it turns on and runs... any help would be great, thanks.
__________________
Accessories:
Front/rear steel a-arm guards
Optima Yellow Top relocated under driver seat
Homecut Polycarbonate windshield
4 -7 lightforce lights 100w
2 PIAA back up lights
Defender rack
2500lb warn winch (dual mount with quick connectors)
indash 2 way momentary switch/external quick connect remote
Wishlist
Viair dual compressors with 2.5g tank.
azar5613 is offline   Reply With Quote
Remove Ads
Old 06-26-2010, 07:02 AM   #2
Member
 
bogmanjr's Avatar
 
Join Date: Jun 2010
Posts: 46
Re: ranger rough idle/sputters/dies

If it has EFI there shouldn't have been a carb to clean. It sounds like you may have a valve adjustment issue to me. At least that's where I would check next.
__________________
I'm a simple man,judge me for my value's not my value!
bogmanjr is offline   Reply With Quote
Old 06-26-2010, 09:34 PM   #3
Member
 
azar5613's Avatar
 
Join Date: May 2010
Location: Kearneysville, WV
Posts: 85
Re: ranger rough idle/sputters/dies

I am going to go to our hobby shop that has everything that I could possibly need so i will check a few things and reply back.
__________________
Accessories:
Front/rear steel a-arm guards
Optima Yellow Top relocated under driver seat
Homecut Polycarbonate windshield
4 -7 lightforce lights 100w
2 PIAA back up lights
Defender rack
2500lb warn winch (dual mount with quick connectors)
indash 2 way momentary switch/external quick connect remote
Wishlist
Viair dual compressors with 2.5g tank.
azar5613 is offline   Reply With Quote
Old 06-29-2010, 02:53 AM   #4
Member
 
azar5613's Avatar
 
Join Date: May 2010
Location: Kearneysville, WV
Posts: 85
Re: ranger rough idle/sputters/dies

So it appears to be fixed. I took the carb off again just to check that everything was fitted correctly. After placing everything back together i started it up and it purred just as it should. I also finally fixed my ignition. I had to get a new one(which on the website stated that it came with the key, ignition, and wire harness. Unfortunately the wire harness option was changed and is sold separately. So with the service manual and some spare wire i made my own. Perhaps while soldering to the ignition something happened to the internal connection between the power and starter combination so i had to add a toggle switch instead. Now i turn the key to on, flip the switch and press the brake pedal to start. Not the original way but it works and it saved me a bunch of money... always good. Depending on the weather tomorrow i plan to take the family out and enjoy some sites.
__________________
Accessories:
Front/rear steel a-arm guards
Optima Yellow Top relocated under driver seat
Homecut Polycarbonate windshield
4 -7 lightforce lights 100w
2 PIAA back up lights
Defender rack
2500lb warn winch (dual mount with quick connectors)
indash 2 way momentary switch/external quick connect remote
Wishlist
Viair dual compressors with 2.5g tank.
azar5613 is offline   Reply With Quote
Old 06-29-2010, 08:09 PM   #5
Member
 
bogmanjr's Avatar
 
Join Date: Jun 2010
Posts: 46
Re: ranger rough idle/sputters/dies

maybe it had a vacuum leak where the carb was fitted to the boot. Glad it worked out for you. Just to warn you in 10 years and 10 months I'll be coming to your state and I want to catch a whole bunch of your fish.
__________________
I'm a simple man,judge me for my value's not my value!
bogmanjr is offline   Reply With Quote
Reply

Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Full Size Ranger Discussion


Search tags for this page
08 polaris 500 ranger poor runno idle
,
2004 polaris ranger sputters and misses after3 miles
,
2006 polaris 500 ranger backfires runs rich
,
2007 polatis ranger 700 dual wont idle
,
polaris 500 running rough
,

polaris ranger 500 efi stalls

,

polaris ranger rough idle

,
polaris ranger running rough
,

polaris ranger runs rough

,
polaris ranger runs rough and stalls
,

polaris ranger will not idle

,
polaris running rough and sputters
Click on a term to search for related topics.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 ranger high idle efi ktjschweg Modified Tech Discussion 1 07-03-2010 05:41 AM
2008 Ranger running rough nvwolfer Full Size Ranger Discussion 0 02-14-2010 03:31 PM
2009 runs rough after warming up. threevalks Full Size Ranger Discussion 5 01-22-2010 09:09 AM
Need help - Rough running Ranger 7lazy77 Full Size Ranger Discussion 4 11-26-2009 11:32 AM
'08 ranger 700 dies when throttle is touched cowboy1 Modified Tech Discussion 5 03-25-2009 10:48 PM


All times are GMT -5. The time now is 06:53 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.