Polaris Ranger 800 crew injectors will not fire - RangerForums.net - Polaris Ranger Forum
Full Size Ranger Discussion Talk about the full-size ranger

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 Old 08-06-2019, 09:34 PM Thread Starter
Spectator
 
TexasPolaris's Avatar
 
Join Date: Jul 2019
Posts: 1
Polaris Ranger 800 crew injectors will not fire

I have checked everything on my Ranger and it has been narrowed down to the injectors not firing. It is at the shop now and the mechanic is stumped. Any suggestions?
TexasPolaris is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-07-2019, 02:48 AM
Sunday Driver
 
Tom-Layla Brough's Avatar
 
Join Date: Sep 2018
Posts: 49
Can the ECU see the reluctor ring? If not it won't know when to fire.. so check the sensor and it's wiring, I've seen them rub through just near the multiplug as polaris often cable ties it too tightly and the 800 vibrates so much the constant movement cuts into the wiring.

The injector wiring can also break at the very top as it goes into the injector itself, they normally develop a misfire first though.
Tom-Layla Brough is offline  
post #3 of 3 Old 08-10-2019, 09:50 AM
Weekender
 
Bluenozer's Avatar
 
Join Date: Aug 2016
Location: Nova Scotia, Canada
Posts: 104
Garage
Just pop them out and crank it over to check if they are spraying and broken wire should set a code

2011 Ranger 800xp
14" Rims
26" Maxxis Tires(Big Horn)
2" Highlifter lift
SuperATV steering rack
SuperATV ARD axles
Bluenozer is offline  
Reply

  Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Full Size Ranger Discussion

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome