Help!!!!! - RangerForums.net - Polaris Ranger Forum
General Discussion Talk about anything here.

 2Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 15 Old 06-18-2019, 07:41 AM Thread Starter
Mountaineer
 
Ranger900HL's Avatar
 
Join Date: Mar 2017
Posts: 294
Help!!!!!

Been having intermittent error code 520226 EPS CAN communications recive error. Fallowed by 190-2 data erratic and 84-2 data erratic or intermittent. Vehicle speed sensor. All fuses check ok, swapped relays, swapped speed sensor, crank sensor, and cleaned all grounds w/ grease. New battery over 12.5 volts. It cuts out the fuel pump, power steering, starter, and headlights. Sometimes go out and starts right up. Other times kicks right into error and dead except cluster works. Any advice would be appreciated.
Ranger900HL is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 06-18-2019, 07:43 AM Thread Starter
Mountaineer
 
Ranger900HL's Avatar
 
Join Date: Mar 2017
Posts: 294
Forgot to mention 2016 ranger 900 HLE. 2400 miles
Ranger900HL is offline  
post #3 of 15 Old 06-18-2019, 08:33 AM
Super Moderator
 
Rockit401's Avatar
 
Join Date: Jul 2010
Location: WKY
Posts: 2,155
Garage
It sounds like a dirty or corroded or loose connection to me.
Some of the older rangers had an inline circuit breaker in the wiring harness, but don't know about the 900's.


2017 Ranger 900 XP
2015 Ace 570
Rockit401 is offline  
Sponsored Links
Advertisement
 
post #4 of 15 Old 06-18-2019, 11:16 AM Thread Starter
Mountaineer
 
Ranger900HL's Avatar
 
Join Date: Mar 2017
Posts: 294
Unfortunately im probably going to cave an take it to the dealer. To bad as i was a week away from trading up to a new model...Ill post the results.
Ranger900HL is offline  
post #5 of 15 Old 06-18-2019, 09:22 PM
Super Moderator
 
Rockit401's Avatar
 
Join Date: Jul 2010
Location: WKY
Posts: 2,155
Garage
Maybe they will still give you a good deal.
Good luck.


2017 Ranger 900 XP
2015 Ace 570
Rockit401 is offline  
post #6 of 15 Old 06-19-2019, 06:25 PM Thread Starter
Mountaineer
 
Ranger900HL's Avatar
 
Join Date: Mar 2017
Posts: 294
Im torn between the gneral 4 and the maverick sport max..
Ranger900HL is offline  
post #7 of 15 Old 06-20-2019, 09:08 AM
Super Moderator
 
Rockit401's Avatar
 
Join Date: Jul 2010
Location: WKY
Posts: 2,155
Garage
That would be a tough decision.
The visco lok front diff would need some research to see how they perform.
I like the more narrow body and track width on the Sport.
The sight angle to the front is not great.
A drive in both is in order.


2017 Ranger 900 XP
2015 Ace 570
Rockit401 is offline  
post #8 of 15 Old 06-29-2019, 06:42 AM Thread Starter
Mountaineer
 
Ranger900HL's Avatar
 
Join Date: Mar 2017
Posts: 294
Well a little update. Been at the dealer soon to be week two. Installed new ecu and still wont start. There tearing into the harness. I am concerned as i ohmd the wiring and didnt see an issue personally. Well see i suppose....
Ranger900HL is offline  
post #9 of 15 Old 07-06-2019, 01:14 PM Thread Starter
Mountaineer
 
Ranger900HL's Avatar
 
Join Date: Mar 2017
Posts: 294
Issue resolved new ecu and fixed a shorted wire by the brake switch.
Rockit401 and jobo2856 like this.
Ranger900HL is offline  
post #10 of 15 Old 07-14-2019, 08:49 PM
Gear Grinder
 
rock2100's Avatar
 
Join Date: Feb 2018
Location: South Dakota
Posts: 218
I just had a the same issue today. I swapped in another ecu and it never changed anything. Same codes as you and no fuel pump or crank over. Nothing works but accessories and hvac stuff. 2019 ranger xp 1000 northstar. Im stumped.
rock2100 is offline  
Reply

  Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > General Discussion

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome