Newbie....Info Needed - RangerForums.net - Polaris Ranger Forum
New Members Tell us a little about you

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 1 Old 07-09-2019, 12:28 PM Thread Starter
Spectator
 
jpmatz's Avatar
 
Join Date: Jul 2019
Posts: 1
Newbie....Info Needed

Hello Everyone,

New to this site!!

I recently acquired a well used '04 (11/2003) Ranger 500 4x4 and the front diff would not engage. I read several threads and decided to remove the front diff figuring the cage was broke. Had a worn out u-joint on front shaft so that needed to be replaced anyway. I ended up replacing all the bearings, seals, Sprague cage and armature plate. Checked magnetic cover (ohmed within spec) and activated with battery voltage applied. When I reassembled everything and did my final checks in the vehicle I found that there was no ground to the magnetic cover. By applying direct ground to that wire and turning on switch 4x4 works fine. Traced the wire back to a solid state module, looks like either RPM limiter or Hub safety according to parts diagram. Does anyone know which one it is and how it is supposed to function? Wondering if module is bad or has a bad signal from some input??

One other problem I have is occasionally the machine will act like the rev limiter is activated just off of idle The machine will be running and idling fine and then on normal acceleration the machine will stutter and miss at all throttle positions. Applying the choke has no impact on it. It will vary on how long it will do it....sometimes 10-15 seconds other 1-2 minutes. My thoughts are either a malfunctioning rev limiter (which appears to be tied to 4WD) or a electronic ignition (stator/CDI) issue. Any insight would be appreciated.

Also what is the best source for a good wiring diagram for this unit?

Thanks,

Jeff <
jpmatz is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > RangerForums.net > New Members

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome