Too difficult to find reverse gear - RangerForums.net - Polaris Ranger Forum
Polaris Ranger 570 Full-Size Discussions for the Polaris Ranger 570 Full-Size vehicles.

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 1 Old Today, 07:28 PM Thread Starter
Spectator
 
showme1946's Avatar
 
Join Date: Aug 2019
Posts: 1
Too difficult to find reverse gear

I have a 2019 570 Full Size, it's about 2 months old. I got a great deal on it at my local dealer, and it is making my life on the farm so much easier. However, there is one characteristic that is frustrating and that is the vague shifter.



In particular, shifting it into reverse is never easy. There is a false neutral where the dash will show "R" but the gearbox will not be in gear. This only happens with reverse. I have to mess with the shifter and press on the accelerator pedal until it finally clicks into gear.


I use the vehicle in Turf mode most of the time because most of my routes involve crossing some part of our lawn, and I don't want it torn up. I don't know if this is a factor or not. When I'm in a pasture I'm usually in 4wd.


I also have a 2007 Sportsman 500 HO, and its shifter is similarly vague, so I suspect this is just a characteristic of Polaris equipment and I'm going to have to live with it, but I thought I'd do a post here and see if anyone has any ideas. Thanks in advance.


George.
showme1946 is online now  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Polaris Ranger 570 Full-Size

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome