hard starting 2013 diesel - RangerForums.net - Polaris Ranger Forum
Polaris Ranger Diesel General Discussions for the Polaris Ranger Diesel

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 2 Old 03-20-2018, 03:57 PM Thread Starter
Spectator
 
gunner2484's Avatar
 
Join Date: Mar 2018
Location: fenelton pa
Posts: 1
hard starting 2013 diesel

I have a crew diesel 2013. It has always stayed outside until this year. I live in northern PA and have never had a problem with the crew starting. I just turn on key let warm up, when the light goes out its starts right up. Now if I don't keep the ranger indoors it will not start without about 10 try's. I wonder if the glow plugs are bad? Or what is my problem? I only run treated diesel.
gunner2484 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-21-2018, 08:19 PM
Mountaineer
 
Ranger900HL's Avatar
 
Join Date: Mar 2017
Posts: 287
Bad glow plug, glow plug relay , or low battery. Thats where id start.
Ranger900HL is offline  
Reply

  Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Polaris Ranger Diesel

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 900 diesel clutch toque values Tommyf Polaris Ranger Diesel 0 07-05-2018 01:17 PM
Problem starting my 2013 Polaris ranger djsteve General Discussion 1 06-05-2018 08:08 AM
2013 Polaris Ranger Diesel Harry Polaris Ranger Diesel 0 05-29-2018 10:35 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome