2016 EV Battery gaguge says 91% after full charge - RangerForums.net - Polaris Ranger Forum
Polaris Ranger EV Discussions for the Electric Polaris Ranger EV.
Sponsored by: Voltronix USA

 15Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 22 Old 11-07-2018, 03:39 PM Thread Starter
Paper Boy
 
Scandi's Avatar
 
Join Date: Nov 2018
Posts: 13
Question 2016 EV Battery gaguge says 91% after full charge

Hi,
I have a 2016 model with ca 250 hours on it. I took it do delivery in the beginning of october-2016 so it is now a little bit over 2 years old.



When i now charge it overnight the dashboard battery indicator does not show 100%, it shows 94-95% and sometimes as low as 91% when i plug out the charger.



I have never mistreated the batteries in any way and i was hoping they would last longer than 2 years before they started getting weaker.



Does anyone have info or experience with this or similar issues, what is possibly wrong, and what can i hopefully do to fix it?


Sincerely


Jørn from Norway
Scandi is offline  
Sponsored Links
Advertisement
 
post #2 of 22 Old 11-07-2018, 05:50 PM
Moon Shiner
 
cricketo's Avatar
 
Join Date: Jul 2018
Posts: 170
Garage
What's the model of the charge indicator ?
Scandi likes this.
cricketo is offline  
post #3 of 22 Old 11-07-2018, 05:56 PM
Wholigan
 
boilermkr's Avatar
 
Join Date: Mar 2014
Location: Clinton, MS
Posts: 1,064
Garage
What is the total voltage of the battery packs? compare that to this scale
Measure with a volt meter. one probe on drivers side rear inside post and one on the passenger side rear battery inside post. + and -. Or you can do each bank individually
Attached Images
File Type: jpg 48Volt.jpg (24.5 KB, 8 views)
Scandi likes this.

2014 Ranger EV
Voltronixs USA 200AH Li-ion Conversion kit
Polaris Lock n Ride Roof w dome light, Mictunning 21.5" Light Bar with green cover lenses, Kolpin ¼" Lexan Full Tilting Windshield,
Thunderhawk front mud shields & fender well protectors, Custom front and rear fender flares.
Custom made rear cargo box mud guards, Eagle eye backup lights, ITP Terracross RT Tires (Front 25x8x12 Rear 25x10x12),
Superwinch Terra 1500 Mounted on rear cargo bed
Overhead Gun Rack
boilermkr is online now  
Sponsored Links
Advertisement
 
post #4 of 22 Old 11-08-2018, 10:53 AM Thread Starter
Paper Boy
 
Scandi's Avatar
 
Join Date: Nov 2018
Posts: 13
Thank you for the chart, i will check this soon.
Scandi is offline  
post #5 of 22 Old 11-08-2018, 10:58 AM Thread Starter
Paper Boy
 
Scandi's Avatar
 
Join Date: Nov 2018
Posts: 13
Attached Images
File Type: jpg GetAttachmentThumbnail.jpg (32.8 KB, 4 views)
Scandi is offline  
post #6 of 22 Old 11-08-2018, 11:06 AM Thread Starter
Paper Boy
 
Scandi's Avatar
 
Join Date: Nov 2018
Posts: 13
Hi i added pictures of it above, because i dont know what model it is cricketo

Last edited by Scandi; 11-08-2018 at 11:11 AM.
Scandi is offline  
post #7 of 22 Old 11-08-2018, 11:55 AM
Moon Shiner
 
cricketo's Avatar
 
Join Date: Jul 2018
Posts: 170
Garage
Quote:
Originally Posted by Scandi View Post
Hi i added pictures of it above, because i dont know what model it is cricketo
Yeah, that doesn't help. The reason I was asking because Curtis has many models of these gauges that look alike, and Polaris may have used several different ones over the years. I was going to pull the docs on yours to see if there is
a reset or calibration function that can be uses, as many Curtis gauges do have ability to calibrate against a fully charged pack. Gauge model number is on the back.
Scandi likes this.
cricketo is offline  
post #8 of 22 Old 11-08-2018, 01:42 PM Thread Starter
Paper Boy
 
Scandi's Avatar
 
Join Date: Nov 2018
Posts: 13
Thanks for the answer, the number is 3003R-57X-0009


then


16143 with C or "O" at he end



on the line under
Attached Images
File Type: jpg GetAttachmentThumbnail.jpg (40.5 KB, 4 views)
cricketo likes this.
Scandi is offline  
post #9 of 22 Old 11-08-2018, 02:16 PM
Moon Shiner
 
cricketo's Avatar
 
Join Date: Jul 2018
Posts: 170
Garage
Quote:
Originally Posted by Scandi View Post
Thanks for the answer, the number is 3003R-57X-0009


then


16143 with C or "O" at he end



on the line under

Nice, that's the same model as I had in my 2015 Ranger. Unfortunately there is no datasheet that I could find for it, but I will give it another try. By the way, check your connector on the back of the gauge, perhaps there is some
oxidation in the connector that results in added resistance.
Scandi likes this.
cricketo is offline  
post #10 of 22 Old 11-08-2018, 02:46 PM
Wholigan
 
boilermkr's Avatar
 
Join Date: Mar 2014
Location: Clinton, MS
Posts: 1,064
Garage
You may want to try resetting it. Charge fully. Disconnect from behind the gauge for 30 seconds and reconnect. It works on the earlier models 2010 to 2013
cricketo and Scandi like this.

2014 Ranger EV
Voltronixs USA 200AH Li-ion Conversion kit
Polaris Lock n Ride Roof w dome light, Mictunning 21.5" Light Bar with green cover lenses, Kolpin ¼" Lexan Full Tilting Windshield,
Thunderhawk front mud shields & fender well protectors, Custom front and rear fender flares.
Custom made rear cargo box mud guards, Eagle eye backup lights, ITP Terracross RT Tires (Front 25x8x12 Rear 25x10x12),
Superwinch Terra 1500 Mounted on rear cargo bed
Overhead Gun Rack
boilermkr is online now  
Reply

  Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Polaris Ranger EV

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
EV advice Thecho Polaris Ranger EV 14 09-17-2018 11:21 AM
2016 EV battery gauge info Juantana Polaris Ranger EV 7 03-19-2018 12:42 PM
Installing Flow-Rite battery watering in an EV OConnorStp Polaris Ranger EV 2 10-28-2017 10:53 AM
2013 Polaris Ranger EV, Full Voltronix USA Lithium Ion Battery Conversion VoltronixUSA Polaris Ranger EV 3 07-11-2017 09:49 PM
Need some help. Considering a 2016 EV. BlakeEatmon Polaris Ranger EV 11 04-12-2016 06:20 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome