Wont stay cranked - RangerForums.net - Polaris Ranger Forum
Polaris Ranger Midsize 500 New Midsize model discussions

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 2 Old 07-02-2019, 01:45 PM Thread Starter
Spectator
 
Maejay's Avatar
 
Join Date: Jul 2019
Posts: 1
Wont stay cranked

Hi y'all!!!! Please help me. Our polaris was running fine until....we loaned it out. Well it sat up for a while until my husband was able to change the primary belt out. We got it running and used it several times. We ran thru some really thick brush and it cut out and we had to tow it home. It will crank but as soon as the gas is give it stalls out. He xhanged the spark plug in it ans u can hear the fuel pump kick on. When it atalls out, it almost apunds like it's congested and needs to fart. It backfires occasionally . he's cleaned put thw gas tank and put new gas in it. Cleanes the filters. Ran seafoam thru it and changed the plug wire with one we had on another polaris. Any suggestions? Do we need to get a brand new plug wire or is something fouling it out.
Maejay is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-03-2019, 08:55 AM
Billy Goat
 
rock2100's Avatar
 
Join Date: Feb 2018
Location: South Dakota
Posts: 199
Does it have a port on the rail for testing fuel pressure. You should probably check that. Check before you start it, after you start it, and when trying to give it gas.
rock2100 is offline  
Reply

  Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Polaris Ranger Midsize 500

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome