Throttle position sensor - RangerForums.net - Polaris Ranger Forum
Polaris Ranger XP900 Discussions for the all new Polaris Ranger XP900

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 Old 07-25-2019, 07:18 PM Thread Starter
Spectator
 
Chuck Atkinson's Avatar
 
Join Date: Oct 2018
Location: Loxahatchee
Posts: 4
Throttle position sensor

Has anyone else had problems with their sensor getting wet? Stalls and sputters for a second then dries out and is good til the next hole. No matter how much I grease it water still gets in. Has there been a fix for this?


Sent from my iPhone using Tapatalk
Chuck Atkinson is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-28-2019, 07:59 AM
Weekender
 
UpNorth2's Avatar
 
Join Date: Jan 2014
Location: Alaska
Posts: 113
Not sure which model and or year Ranger you have. If yours has a fly by wire throttle that could be what is getting wet.
UpNorth2 is offline  
post #3 of 4 Old 07-28-2019, 08:03 AM Thread Starter
Spectator
 
Chuck Atkinson's Avatar
 
Join Date: Oct 2018
Location: Loxahatchee
Posts: 4
Damn I forgot to put it in. I have 16 highlighter. 2 seater. Itís the sensor attached to the gas pedal. Hoping they came out with a upgraded sensor or some kind of sealer to go around it or something


Sent from my iPhone using Tapatalk
Chuck Atkinson is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 08-12-2019, 11:43 AM
Paper Boy
 
Hgallof's Avatar
 
Join Date: Feb 2016
Posts: 10
I’m having the same issue. Where you able to find a fix? Thanks.
Hgallof is offline  
Reply

  Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Polaris Ranger XP900

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome