2013 XP900 Error Code 520275 - RangerForums.net - Polaris Ranger Forum
Polaris Ranger XP900 Discussions for the all new Polaris Ranger XP900

 1Likes
  • 1 Post By Rockit401
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 7 Old 08-30-2019, 07:46 PM Thread Starter
Paper Boy
 
roy509's Avatar
 
Join Date: Aug 2011
Location: Loon Lake, Wa.
Posts: 16
2013 XP900 Error Code 520275

Can someone please tell me what error code 520257 with number 31 below means on 2013 Ranger XP900. Also any ideas as to possible cause would be appreciated. It goes in to what I believe to be "limp mode" until you pump the accelerator a couple of time then it seems to snap out of it for some time.

Thank You
roy509 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 08-31-2019, 12:12 AM Thread Starter
Paper Boy
 
roy509's Avatar
 
Join Date: Aug 2011
Location: Loon Lake, Wa.
Posts: 16
My apologies, the error code is 520275. With the #31 below.

Thank You
roy509 is offline  
post #3 of 7 Old 09-01-2019, 07:58 PM
Moon Shiner
 
liftedpsd2010's Avatar
 
Join Date: Jul 2016
Posts: 166
Do you ever try to use the brake while pushing the gas?


Sent from my iPhone using Tapatalk
liftedpsd2010 is online now  
Sponsored Links
Advertisement
 
post #4 of 7 Old 09-02-2019, 09:26 PM Thread Starter
Paper Boy
 
roy509's Avatar
 
Join Date: Aug 2011
Location: Loon Lake, Wa.
Posts: 16
No, if so not intentionally..
roy509 is offline  
post #5 of 7 Old 09-02-2019, 09:27 PM
Moon Shiner
 
liftedpsd2010's Avatar
 
Join Date: Jul 2016
Posts: 166
Quote:
Originally Posted by roy509 View Post
No, if so not intentionally..


That code is common when hitting the brake and gas at the same time.


Sent from my iPhone using Tapatalk
liftedpsd2010 is online now  
post #6 of 7 Old 09-03-2019, 08:13 AM
Super Moderator
 
Rockit401's Avatar
 
Join Date: Jul 2010
Location: WKY
Posts: 2,165
Garage
It could also be the brake light switch not releasing when it should.
liftedpsd2010 likes this.


2017 Ranger 900 XP
2015 Ace 570
Rockit401 is offline  
post #7 of 7 Old Yesterday, 11:42 PM Thread Starter
Paper Boy
 
roy509's Avatar
 
Join Date: Aug 2011
Location: Loon Lake, Wa.
Posts: 16
Thank you for the reply. Some piece of mind it is nothing serious.
roy509 is offline  
Reply

  Lower Navigation
Go Back   RangerForums.net - Polaris Ranger Forum > Polaris Ranger Forum > Polaris Ranger XP900




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome