Polaris Ranger Forum banner

electrical

  1. EV 2010 Electrical Problems

    Polaris Ranger EV
    We have a EV Polaris 2010, we have an electrical problem we put the cart on charging and the next day the cart do not start the dash lights do not turn on neither solenoid, and ligths , just the battery condition meter turn on. do you know something that can help us? please or any sugesttion...
  2. Ranger HD doesn't act right after washing it

    General Discussion
    My Ranger HD doesn't run right after it has been washed or goes thru water.....something is getting wet I know it's just where should I start looking??? Any thoughts would be appreciated.
  3. Cooling fan and winch aren't working

    General Discussion
    Winch stopped working 2014 Ranger800 EFI. Tried to pull a kid out buried in mud. My winch, 4500 Polaris brand installed by the dealer, stopped working. Checked the fuses under the hood, they were fine. When I try to winch in or out, I hear a click noise coming from the winch, but nothing...
  4. 2000 6X6 Dies after a while

    Polaris Ranger 6X6
    I have a 6X6 that has been cutting out. It usually happen by the time I get to the back of my property and I have to walk all the way back. Symptoms: -When it dies the neutral light is not glowing (Yes, it is in neutral). -After a while I turn on the ignition and the green light is back on...
  5. Keyed Power Terminal

    Full Size Ranger Discussion
    I have a 2011 Ranger 500EFI. Does anyone know which terminal is the Keyed Power Terminal? The bottom post has a single red wire, the one in the middle a single brown wire, and the top one has four colored wires including two that look to be orange and white. (I assume it is the top one, but I...
  6. Found cut wires?

    Full Size Ranger Discussion
    I found these two wires that just end and look like they connected to each other and were chewed through. This doesn't really make much sense to me as they both come out of the same connector clip and then just connect to each other? They are black and come out of a clip in the front left area...
  7. 06 ranger loses all electrical power

    Modified Tech Discussion
    I have an 06 ranger EFI i use for deer hunting, it does not like cold weather it runs just perfect in the shed take it to the field when it is cold and it loses all electrical power. i push it in the shed and let it warm up and it runs perfectly take it to the shop they put it insde it runs...
Top