Polaris Ranger Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. Polaris Ranger 500
    As the title states i have a 2011 ranger 500 efi, the machine starts and runs perfectly for about 10-15 minutes. after im assuming it gets warm it will just die out and WILL NOT START until it cools down around 15-30 minutes later. it is still getting spark for the most part, seem kind of...
  2. Full Size Ranger Discussion
    My 800 xp wouldn't start after riding for 5 min. These are the things i tried..... 1. Cranked ignition until battery died. (Recharge battery) 2. Pulled plugs checked for spark...ok 3. Pulled fuel rail hose checked flow..ok 4. Checked grounds and connections..ok 5. Sprayed fuel into air...
  3. Polaris Ranger XP900
    I have a 13 ranger 900xp and I’m having an injector issue on. I have to have the injector connectors crossed to get it to start. So like I have cylinder 2 connector on cylinder 1 and cylinder 1 connector on cylinder 2. With the connectors like this the ranger starts and runs but will pop out the...
  4. Polaris Ranger XP900
    Does anybody have any experience removing the fuel injectors from a 2014 ranger XP. I tried pulling on them and it seems inordinately difficult and don't want to break them. I don't see a clip and can't find a reference on youtube. Bruce
  5. Polaris Ranger Midsize 500
    My Ranger has recently started acting up. I believe some water got into the fuel system last week. Tank has been drained and refilled but performance issues have remained. Lag, backfire and will occasionally stall out but will restart after a minute or so. Feels like ignition has been turned off...
  6. General Discussion
    I bought a used 2010 Ranger 800 EFI HO...Having injector problems and tracking down the injector numbers it appears that 2012 injectors were installed on a 2010 unit.... 2010 calls for pt. # 1202863. The injector wire numbers presently on the engine are pt.#s 1204318 (black) MAG, 1204319 (Gray)...
1-6 of 6 Results
Top