Polaris Ranger Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Ok, my 08 ranger has developed a front dif problem, I changed the oil and then some time later the front wheels wanted to scuff. Just seemed to be a problem in 1 or 2 wd. I ran it in 4wd to finish picking rock. After some reading I decided to remove the front diff. I had 14 volts with switch in AWD and -14 in 1 or 2 WD. Diff was clean as a whistle, cage looked ok, with one small plastic piece split off under the H spring. My cage has 14 rollers in 2 of rows. I took the diff apart and hooked back up to switch and couldn't seem to get any magnetism. Would too much oil cause original issue"s? I had fun getting the front plug out and filled until it ran out. I'll put new cage in, but wondering what actually is causing the issue. 4WD did work, but would Not release. scuffing did'nt happen all the time. I would back up to get it to release. Did polaris update the cage? Is the JD one for the gator hxp a heavier version? Any other Idea's?
 

Attachments

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Ok, I have my ranger back together. I installed a New plastic roller cage from Quad Logic, came with the H springs. and just under 100.00 cheaper than polaris with rollers, 307.00 Seems to work so far. didn't test it much, drove around the yard and in the field.. time will tell. Oh and here's a photo of my utv lift. best 800.00 I ever spent for my shop..
 

Attachments

1 - 2 of 2 Posts
Top