Polaris Ranger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have been reading some of the threads about the Brake Pressure Sensor because I thought that was the issue. I jumped the sensor and have the same symptoms.

The brakes are super soft. The engine will turnover but it will not stay running unless I keep the key turned.

I am NOT a mechanical guy but I can usually get it done. Any help diagnosing would be a great help
 

·
Registered
Joined
·
369 Posts
Don't know how many hours it has on it.
When you crank it. Give it some gas with it in neutral.
If it runs then.
You may have to adjust your valves.
My crystal ball is a little foggy today too.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I almost always put it in Neutral when I try and start it and it doesn’t matter about giving it gas. It doesn’t stay started long enough to give any.
 

·
Registered
Joined
·
369 Posts
How old is your gas.
How old is your fuel filter.
Do you keep Starbrite startron in your fuel.
Do you have water in your gas.
What octane gas do you have .how old are your spark plugs.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Let me add some back story. I use this for almost exclusively. It started and ran fine. I drove it to where I was working, maybe a 20 minute drive. Fairly easy drive but one spot was muddy with some ruts but nothing to bad. I parked it and it sat for maybe an hour. Would start again. This was about 3 weeks ago.

filled the tank that morning.
Did normal maintenance about a year ago, which included filter and plugs.
I have no idea what Starbrite Satron is so No.
The chance of water in the fuel is almost zero.
I only use ethanal free gas.
 
1 - 5 of 5 Posts
Top