Polaris Ranger Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
I have a 2018 570 midsize that will start right up and run for a couple minutes then shuts off like the key was turned off. I can turn the key off and then turn it back on and it will start again but will run about half as long as it did the first time. it will run about half as long each time that I start it. The machine has just over 120 miles and 50 hours. I sure could use some help with this if anyone has had this problem please let me know how to fix it. Thank you.
 

·
Registered
Joined
·
10 Posts
I have a 2018 570 midsize that will start right up and run for a couple minutes then shuts off like the key was turned off. I can turn the key off and then turn it back on and it will start again but will run about half as long as it did the first time. it will run about half as long each time that I start it. The machine has just over 120 miles and 50 hours. I sure could use some help with this if anyone has had this problem please let me know how to fix it. Thank you.
I would look into the fuel pump or wiring connection to it. Had the same problem, and replacing the pump took care or it
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks for the info, I will check it out. I can't believe this thing is needing worked on when it only has 120 miles on it! The power steering only works about half the time as well. This is my first s x s and will most likely be my last. I have an old 2000 arctic cat ATV I bought new that is still running good. Just regular maintenance performed on it.
Sorry for all the ranting but it is hard to believe I have to start pouring money into this thing already. I thought that only happened with bass boats! Have a great day.
 

·
Registered
Joined
·
92 Posts
Check the reg/rect. It's rare but I've seen a couple bad ones send a voltage spike and shut off the cdi. Tough to find unless you can unplug the reg/rect. Having to turn the key off and back to on is also another tip off. Have the power steering reflashed. Should fix that problem.
 

·
Registered
Joined
·
74 Posts
Thanks for the info, I will check it out. I can't believe this thing is needing worked on when it only has 120 miles on it! The power steering only works about half the time as well. This is my first s x s and will most likely be my last. I have an old 2000 arctic cat ATV I bought new that is still running good. Just regular maintenance performed on it.
Sorry for all the ranting but it is hard to believe I have to start pouring money into this thing already. I thought that only happened with bass boats! Have a great day.
Leaving these machines sit is the worst thing you can do to them…. Its usually the low milage machines that have the issues
 
1 - 8 of 8 Posts
Top