Polaris Ranger Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My 2019 Polaris Northstar Ride Command gps will load up but not stay up very long and starts jumping back and forth from night to day mode with no trails on them. But it still tracts my ride I’m on!???
 

·
Registered
2020 Ranger XP1000 Northstar Ultimate Crew
Joined
·
74 Posts
For the day/night switching it sounds like the auto day/night mode is selected on. Theres a notch in the plastic (upper right i think…not by my machine) which is where the sensor is. Mine does the same thing at times. Just depends if im around trees it seems. Sometimes it’s annoying but I usually forget about it and dont adjust it to either a day or night setting.

Hit the center Polaris button on the RC screen and make sure the controls button is blue on the screen with gauges, phone, music, etc buttons on left side. Under the word controls is the brightness slider with the auto check box on the right of the screen. See if that helps ya out.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
For the day/night switching it sounds like the auto day/night mode is selected on. Theres a notch in the plastic (upper right i think…not by my machine) which is where the sensor is. Mine does the same thing at times. Just depends if im around trees it seems. Sometimes it’s annoying but I usually forget about it and dont adjust it to either a day or night setting.

Hit the center Polaris button on the RC screen and make sure the controls button is blue on the screen with gauges, phone, music, etc buttons on left side. Under the word controls is the brightness slider with the auto check box on the right of the screen. See if that helps ya out.
That doesn’t bother me it’s the fact that the trail and ride map doesn’t display for very long becomes very intermittent!
 

·
Registered
2020 Ranger XP1000 Northstar Ultimate Crew
Joined
·
74 Posts
Check this recent thread out. See if your red dots turn green.

 
1 - 4 of 4 Posts
Top