Polaris Ranger Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Our new Ranger worked fine when we put it away. Now it wont start. It clicks but that is it. The lights come on and the fuses have been checked. I drive very slowly-to the point I annoy my daughters so not sure what it could be.
 

·
Super Moderator
Joined
·
2,506 Posts
Check battery connections.
Check your brake lights.
Load test battery.
 

·
Registered
Joined
·
66 Posts
Our new Ranger worked fine when we put it away. Now it wont start. It clicks but that is it. The lights come on and the fuses have been checked. I drive very slowly-to the point I annoy my daughters so not sure what it could be.
Are you stepping on brake petal when you are trying to start?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Battery has power-all the lights and computer work, checked all connections , I can have my husband load test battery. Thanks for suggestions!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Are you stepping on brake petal when you are trying to start?
Yes -I so wish that was issue. We checked all connectors. Battery has power wont turn over-just clicks. Maybe bad starter. Sad thing is the dearlership we bought it off of cant fix it till July! This is terrible. IT is under warranty-hopfully-we havent even made on payment. This is bad luck! Found another dealership to take it back to.
 

·
Registered
Joined
·
66 Posts
Yes -I so wish that was issue. We checked all connectors. Battery has power wont turn over-just clicks. Maybe bad starter. Sad thing is the dearlership we bought it off of cant fix it till July! This is terrible. IT is under warranty-hopfully-we havent even made on payment. This is bad luck! Found another dealership to take it back to.
Someone else said they had an issue that he had to step down as hard as he could on brake to get his 1000 to start
 

·
Registered
Joined
·
66 Posts
Yes -I so wish that was issue. We checked all connectors. Battery has power wont turn over-just clicks. Maybe bad starter. Sad thing is the dearlership we bought it off of cant fix it till July! This is terrible. IT is under warranty-hopfully-we havent even made on payment. This is bad luck! Found another dealership to take it back to.
What did they find out?.
 

·
Registered
Joined
·
2 Posts
Hey, my 2020 ranger crew 1000 would not start today. It was fine yesterday but I got on it today and when I turned the key the instrument panel started flashed and when I turned the key it just clicks. I checked the battery and it had alot of corrosion on the positive terminal. I cleaned it all up and put it back in but still just clicking noise. I took the battery to Auto zone and after diagnostics were done, he said it a good battery and reading 100% charged. I'm not sure where to go from here. It did sit out in the rain the past couple days due to having no shelter accessible.
 

·
Registered
Joined
·
164 Posts
My brothers 2020 would do that too…he would have to jiggle the ignition key back and forth and it would fire up. Dealer told him they had several that had ignition switch issues.

not sure if same on y’all’s, but if it starts when you turn key back and forth several times that’s the issue I’m thinking.
 
1 - 10 of 10 Posts
Top