Polaris Ranger Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
This is my first post here. I purchased a new 2021 Ranger 1000 Crew Premium (Non-XP) about a month ago. It’s a stock machine with no upgrades. I love the machine so far but I had to take it back to the dealership today. I mostly drive with turf mode turned on. The family and I were out riding logging roads yesterday. I was driving average between 5-15 MPH in low gear and had the rear differential locked because we were going up and down some steep hills. Out of nowhere the check engine light came on and there was a slight smell of plastic burning. There were two diagnostic codes that appeared. The first code was a 520207 with the number 4 above it. The second code was 746 with the number 5 above it. At this point I got back on the main road and headed home. When I turned into my driveway I noticed that both back wheels were still locked even though I was in Turf mode. When I got home I looked up the codes on the internet and based on previous owners experience these codes always came from issues with Turf mode and typically mean something with the Turf mode solenoid, relay switch, or fuse going bad. The relay switch on the older Rangers appeared to be behind the muffler. However I could not find it on the 2021 model. I opened up the fuse box and immediately found my problem. The Turf Mode Relay switch appears that it is in the fuse box and it was completely melted. I’ve attached a picture of the issue and code. I’m posting this here so that it will help someone else in the future because this forum help me track down the code. I will reply back to this thread once I get information back from the dealership on the actual problem.
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
This is my first post here. I purchased a new 2021 Ranger 1000 Crew Premium (Non-XP) about a month ago. It’s a stock machine with no upgrades. I love the machine so far but I had to take it back to the dealership today. I mostly drive with turf mode turned on. The family and I were out riding logging roads yesterday. I was driving average between 5-15 MPH in low gear and had the rear differential locked because we were going up and down some steep hills. Out of nowhere the check engine light came on and there was a slight smell of plastic burning. There were two diagnostic codes that appeared. The first code was a 520207 with the number 4 above it. The second code was 746 with the number 5 above it. At this point I got back on the main road and headed home. When I turned into my driveway I noticed that both back wheels were still locked even though I was in Turf mode. When I got home I looked up the codes on the internet and based on previous owners experience these codes always came from issues with Turf mode and typically mean something with the Turf mode solenoid, relay switch, or fuse going bad. The relay switch on the older Rangers appeared to be behind the muffler. However I could not find it on the 2021 model. I opened up the fuse box and immediately found my problem. The Turf Mode Relay switch appears that it is in the fuse box and it was completely melted. I’ve attached a picture of the issue and code. I’m posting this here so that it will help someone else in the future because this forum help me track down the code. I will reply back to this thread once I get information back from the dealership on the actual problem.
Update on this issue. Dealer couldn't find anything wrong with the wiring or the turf mode solenoid. He thinks it was just a bad relay. Said he has never seen a relay fail like this in all his years of working on them. I'm crossing my fingers that it is indeed just a faulty relay.
 

·
Registered
Joined
·
32 Posts
Thank you very much for posting this. I am waiting for my Ranger 1000 to come in, I had to order one. I will keep my eyes open for this. I hope this is not a common problem.
 

·
Registered
2021 Camo 1000 XP
Joined
·
89 Posts
I think your dealer is pulling your leg. The relays are replaced much more often than the solenoids. Maybe not on a 2021 but overall. Replaced mine on my 2015 2 months ago.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I got my ranger back this weekend. We'll see if it happens again. I ordered the 2'' Prolift and got a great deal on the new Badlands 5000# winch from the Harbor Freight black Friday deals and coupons. Installing them will be my rainy day project in the future.
 
1 - 5 of 5 Posts
Top