Polaris Ranger Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Under the hood of my 570 ranger mid size is an electrical stripe ? It is a plastic that is bolted down it has three bolts sticking out of it one of the bolts has a electrical wire coming from the wiring harness. when the key is on you can touch the bolt with the wire and it will light the electrical tester which is grounded. When you touch the next bolt down where you can attach a wire. when I put the tester on it will show no power.
I was told by the Polaris sells man that that strip was where you could attach electrical lights or sprayers.
I am trying to hook up a sprayer.
thanks Rock
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Thank you for the info

The idea of running wire from the + and - from the battery to the two lugs . from the + lug I can put a switch and run the + wire back to the hook up for the sprayer which lets me turn it off and on from the dash switch I will run the ground wire from the lug to the sprayer hook up.
Thanks again I think I can do this .
Rock
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
Dose any one out there with the 2015 Polaris 570 ranger factory manual, is there a good wiring schematic which shows how it all lays out
 

·
Registered
Joined
·
227 Posts
I just checked my 2015 570 Crew EPS manual and there is no wiring diagram. Sorry
 

·
Registered
Joined
·
38 Posts
That block is to use as needed for positive or negative but must be wired as such. If you want positive from the switch you must run a jumper. Same for non-swiched positive or negative. I used one lug for wiring two sets of led lights and used one lug for grounds. Just be sure to mark + or - for others trying to help you wire something. I generally paint the terminals red or Black...
 

·
Registered
Joined
·
2 Posts
Under the hood of my 570 ranger mid size is an electrical stripe ? It is a plastic that is bolted down it has three bolts sticking out of it one of the bolts has a electrical wire coming from the wiring harness. when the key is on you can touch the bolt with the wire and it will light the electrical tester which is grounded. When you touch the next bolt down where you can attach a wire. when I put the tester on it will show no power.
I was told by the Polaris sells man that that strip was where you could attach electrical lights or sprayers.
I am trying to hook up a sprayer.
thanks Rock
 

·
Registered
Joined
·
2 Posts
New to the Forum,
I have a 2014 Ranger 570.
I’m having almost the same problem with no power to the ignition switch, therefore, no power to the starter Replaced battery, solenoid, and ignition switch. My problem started when I installed a light bar, and winch. I wasn’t aware of the strip having hot and negative sources. My question; is there a fuse link or fuse going to the strip ? If so, maybe I have grounded it and blown the fuse.
I can jumper the solenoid, and it will crank. That rules out a bad starter. Please help, I bought it used, and have only ride it 1 time. Driving me crazy.
thanks
 
1 - 10 of 10 Posts
Top