Polaris Ranger Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
First off, let me introduce myself. My name is Josh and I'm currently in Baghdad although I'm from MI. We inherited a Ranger 6X6, I believe its an 05 500. Well the group of guys before me beat the snot out of the thing and never did any maintenance on it. I'am very very limited on parts so I did what I could to it. Cleaned the plug, new air filter, complete lube. I had been driving for like two weeks and this thing hauled a$$. I took it through some mud and had a great time. I power washed it, dryed it off, and now it runs like poop. AF is good, plug is good. Should I pull off the carb and make sure everything is clean? I took off the pre-cleaners and hosed them out and thought I might have put them on the wrong way, and I did. I swapped them back to where I thought they should be ( big hole on the intake hose) and still no help. Sorry for the long post but does anyone have any suggestions?
 

·
Registered
Joined
·
563 Posts
I am not a mechanic, so I can't help you. But here is a link to the service manual for your machine.http://www.militaryatvparts.com/parts_diagrams/2005_Polaris_Ranger_2x4_4x4_6x6_R05RB50AA.pdf
 

·
Registered
Joined
·
2,273 Posts
What is it doing, does it run rough? Will it idle? Does it crank up at all. How much fuel is in it? Is it getting fuel to the carb? Check spark plug again, maybe not firing enough.

What did you flush out with the hose? What are you calling precleaners? If you sprayed the air filter out then you might not have gotten all the water out. Have you tried running it without the filter in? Did you hose it while it was running?

Josh
 

·
Registered
Joined
·
563 Posts
After you go to the pdf site for the service manual, in the seach function at that site type in: filter, breather That will take you directly to the diagram of the air filter s$$embly. Hope this helps.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Thanks for the link! It doesn't run rough or idle rough. I have filled the tank twice since the problem occured. I will take a look at the carb and the plug again. Is there an inline fuel filter before the pump? The pre-cleaners I'm thinking of are the intake boots under the "hood" with the plastic mesh looking filter in it. I blew those out with air after I washed it and still no help, I replaced the AF after this all happened. What about clutch and belt probs? I have been reading everything I can, and from what I can gather that if the clutch and belt are worn a decrease in power can be had. What I don't understand is that if the belt is slipping, won't it over-rev? I forgot to add something to my first post, when its in neutral and you floor it, it screams and revs up very smoothly. When your in high and get going I just don't hear the same exhaust note.
 

·
Registered
Joined
·
563 Posts
To find the fuel filter in the pdf service manual type: "fuel tank" in search. Go up 1/2 page. The fuel filter is on page 62. item # 24. It looks like the fuel filter is just before the pump. I can"t help with the rest of your questions. :(
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Well I got it!! So I was looking through everything and decided the belt was worn, so I changed it. I took off the carb and was looking in it and saw this little door looking thing that I can only assume is some type of vaccum choke. The little piece of hose on the top of the carb was torn. I put the carb back on, started it, held the little door up and plugged the whole with me finger and the old girl screamed. I didn't have that type of plugged hose so I took a chunk of hose and put a screw in it, some clamps and took it for a ride. OMG its fast. I think its faster than when we first got it. Thanks for your help everyone!!
 

·
Registered
Joined
·
563 Posts
It looks like necessity is the mother of....... Good to go!!!!! Great!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
Here are some pics..

A friend of mine built a recovery system on this ranger. He fabbed up the lift and tree, used a 4k winch off a gator with an optima and it works great.



Here is my Ranger


Paper weight Lol!


On Camp Slayer. Saddam had all the lakes built here. Former Baath Party headquarters in the background.


My old wrecker


We convoyed to Tallil


I was at Camp Bucca for a few months, then we got re-missioned to Baghdad. Its alot nicer here, only down fall is there's a hell of alot more rockets. Lol!!





[attachment deleted by admin]
 
1 - 11 of 11 Posts
Top