Polaris Ranger Forum banner

1 - 7 of 7 Posts

·
Registered
2020 Polaris Ranger 1000 Crew Premium
Joined
·
1 Posts
Discussion Starter #1
I have installed a 3" Lift Kit from Super ATV and 2" Aluminum Orion Wheel Spacers (Amazon) on my 2020 Polaris Ranger 1000 Crew Premium (Not the XP Version but the new XP 900) and I seem to have a clicking noise coming from the rear. I cant tell if it is my CV Shaft binding or what. I only notice it in slow speeds and it is random, but in sequence of 2-3 clicks each time.... I am fairly certain I got it installed correctly and I am fairly mechanically inclined but thought this was the only thing that could have went wrong.... I did 65ft/lbs on the 2" Aluminum Spacers and my wheels. My owners manual says 60ft-lbs for steel rims and 120ft-lbs for aluminum which I thought was WAY to tight.... Anyone have a solution to this problem or have been experiencing the same issue?
 

·
Registered
Joined
·
313 Posts
120 is not way too tight. It's what's called for and would stick to it. A friend ruined a rim and lug studs because he thought 120 might be to much. 2 missing lug nuts and a ruined rim showed him otherwise.

Even though they sell them, 3" lifts are hard on axles. General rule, 2" max for avoiding problems. I recommend jacking the front and rear....doesn't have to be at the same time.....off the ground and spinning the wheels by hand. And front, turn the steering full lock right and left and spinning the wheels. If its binding you'll know.
 

·
Registered
Joined
·
58 Posts
Most likely a cv joint... i had problems when I installed my lift. I swaped out all 4 axles to Rhino....all is great now
 

·
Registered
2020 Ranger Northstar
Joined
·
230 Posts
Stock axles will bind at full droop. I have a set of rhino 2.0 to install. I put a a 2.5” lift on mine.
 

·
Registered
Joined
·
21 Posts
Could be wheel bearings. I had to change 3 of them on my 2018 ranger 1000 at 2000 miles.
 

·
Vendor
Joined
·
402 Posts
You probably have a CV getting ready to pop. The Rhino 2.0's are a major HD upgrade, and generally considered the best bang for the buck. Hit me of for a little discount if you want to pull the trigger.
 

·
Registered
Joined
·
3 Posts
I have installed a 3" Lift Kit from Super ATV and 2" Aluminum Orion Wheel Spacers (Amazon) on my 2020 Polaris Ranger 1000 Crew Premium (Not the XP Version but the new XP 900) and I seem to have a clicking noise coming from the rear. I cant tell if it is my CV Shaft binding or what. I only notice it in slow speeds and it is random, but in sequence of 2-3 clicks each time.... I am fairly certain I got it installed correctly and I am fairly mechanically inclined but thought this was the only thing that could have went wrong.... I did 65ft/lbs on the 2" Aluminum Spacers and my wheels. My owners manual says 60ft-lbs for steel rims and 120ft-lbs for aluminum which I thought was WAY to tight.... Anyone have a solution to this problem or have been experiencing the same issue?
Maybe why MMA LIFT Kit raise is 2.5”. Not too much but enough to take care of business?
 
1 - 7 of 7 Posts
Top