Polaris Ranger Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I have a 2012 Ranger 800 EPS and have used the Glacier II Plow system. I really like it except for two problems. My Polaris winch will stop working intermittently and because of this, I found the second problem. The mounting bracket to the ranger has two cracks, or tears, on the front top. Has anyone else experienced this? Anyone else have an intermittent problem with the winch stopping? Thanks in advance.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
Well, got the bad news yesterday. My winch was toast and they can't do anything because it is two years old. Put a Warn 4.0 CI winch on as a replacement. It was the only winch the dealer had in stock to put on and it is a discontinued model. Local welder repaired and beefed up the bracket. $1500 lighter after the 100 hour service, new winch and diagnosis of the winch. 2 1/2 years of heavy use and no other problems. If this gets me another 2 1/2 years of problem free use, I'll be less upset. Parts and labor for the 100 hour service totaled about $700. $350 in parts, $350 labor. New belt, some clutch parts, filters, fluids and seals for parts.
 

·
Registered
Joined
·
171 Posts
The intermittent prob could be battery related or the contactor.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
They charged $100 to tell me the winch was shot. The contractor was replaced last year. I think it's bad bad since it was new.
 
1 - 4 of 4 Posts
Top