Polaris Ranger Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have had my Northstar for about a month now and the GPS lost communications while riding. I have checked the cable from the puck to the back of the command screen module and everything is good. I have upgraded all the maps and software. It did come on yesterday morning but again on a ride it failed again. I have disconnected the battery and let it sit for 30 min and then re-installed all maps and software but to no avail.....

Kinda frustrated to spend 30K to have this problem. I have even reset the Command by pushing the Polaris button and the Map button but I get nothing. The first time it reset was when it sat out side all night, but then failed on a ride. I really need this when I get back in the mountains of Utah because it is big country.

Any help short of taking it to the Dealer and not seeing for the rest of summer would be nice.
 

·
Registered
Joined
·
6 Posts
I have had my Northstar for about a month now and the GPS lost communications while riding. I have checked the cable from the puck to the back of the command screen module and everything is good. I have upgraded all the maps and software. It did come on yesterday morning but again on a ride it failed again. I have disconnected the battery and let it sit for 30 min and then re-installed all maps and software but to no avail.....

Kinda frustrated to spend 30K to have this problem. I have even reset the Command by pushing the Polaris button and the Map button but I get nothing. The first time it reset was when it sat out side all night, but then failed on a ride. I really need this when I get back in the mountains of Utah because it is big country.

Any help short of taking it to the Dealer and not seeing for the rest of summer would be nice.
I had my antenna go bad.
 
1 - 3 of 3 Posts
Top