Polaris Ranger Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello All, I just bought my first Side by side. If anyone has any input or can direct me to where I can get some answers, that would be great. When you first start it cold, it sputters and acts like it wants to stall. You have to pump the throttle to get it going and once the engine warms up, it runs fine-ish. It only tops out at 30mph when I’ve been told they should go 50-60. It will also occasionally stall at idle after the engine has warmed up.
the fuel pump has been replaced and it has a fresh tank of premium,& new air filter.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Really the parking brake? That is one thing that doesn’t work. I haven’t looked at it to see if the cable came loose or what.
 

·
Registered
Joined
·
164 Posts
Do you happen to smell gas in exhaust fumes? At risk of sounding like a broken record, I would take a look at the valve lash…you can google how to check the valve settings and set them with dealer gage. Worth checking as it’s quick, easy and free.

What happens if valves aren’t set it interferes with control of intake vs output from combustion chamber of engine….as engine heats up and metals expand it runs better (not best) as the expansion brings valves closer to proper setting.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Do you happen to smell gas in exhaust fumes? At risk of sounding like a broken record, I would take a look at the valve lash…you can google how to check the valve settings and set them with dealer gage. Worth checking as it’s quick, easy and free.

What happens if valves aren’t set it interferes with control of intake vs output from combustion chamber of engine….as engine heats up and metals expand it runs better (not best) as the expansion brings valves closer to proper setting.
Thanks! I’ll definitely look into that
 

·
Registered
Joined
·
80 Posts
Not explained well by me, sorry. The parking brake, when on will cause the engine to misfire, That protects from wearing the brake part. Check if the brake is adjusted right and all the way off
 

·
Registered
Joined
·
128 Posts
I actually ordered new injectors, air idler sensor, tps, complete maintenance kit, & spark plug wires for it. So hopefully with all that replaced it’ll run like a champ
I use a 9 volt battery and b12 and back flush them ,
If that's the problem I order a set

Sent from my SM-G975U1 using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #12 ·
I take them out , you and connect a 9 volt battery to the injector and it will open it , back flush with Berryman B12 spray and compressed air and most time it clears them

Sent from my SM-G975U1 using Tapatalk
Oh okay. Thanks for clarifying, I didn’t know you could do that.
 

·
Registered
Joined
·
23 Posts
Also run some Sea Foam in your gas once in awhile, it really cleans injectors and carbs.
Used it for many years it also helps to displace water in the gas.
 
1 - 18 of 18 Posts
Top