Polaris Ranger Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I updated one bank of my batteries to a lithium 12 volt 100ah battery. After doing so I drove the utv slowly and things were fine. Once I floored it the utv died and just clicked and flashed the lights on the dash.
The controller lights flash 12 times, I was able to reset everything by checking the fuses and the same thing happens. Seeing voltage at 53 so not sure if that's too high and causing the issue?
Help?
 

·
Registered
Joined
·
301 Posts
I updated one bank of my batteries to a lithium 12 volt 100ah battery. After doing so I drove the utv slowly and things were fine. Once I floored it the utv died and just clicked and flashed the lights on the dash.
The controller lights flash 12 times, I was able to reset everything by checking the fuses and the same thing happens. Seeing voltage at 53 so not sure if that's too high and causing the issue?
Help?
53V is not too high.

The UTV will cut out when the battery voltage drops below 42V. I'd check the battery cables and make sure they are clean, and making good contact with the batteries.

That's what I'd check first.
 

·
Registered
Joined
·
648 Posts
12 flashes is a can bus error, but can bus isnt used to communicate around the vehicle. If it is 12 flashes then it could be an internal error in the Sevcon.With only one bank and 100ah thats way too low even Li ion will drop badly at the sort of discharge you would expect to see under heavy load. If you still have the originals on the other side then you will also be seeing a big voltage drop and that will take down the voltage on the Li ion side. Its really not a good way to do this. All or nothing with a proper BMS connecting to all the cells. 11 flashes includes over current, and that will happen if voltage drops too low.
 
1 - 3 of 3 Posts
Top