Polaris Ranger Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hey guys, I am new to this forum. Today me and my son took out my 2011 Ranger 400 H.O., on a steep climb we lost traction and couldn't climb any further. We did spin somewhat while trying to make the climb. I backed down the hill and there was a loud clunking noise coming from the rear in reverse and drive. Does anyone have a suggestion or solution? I live 120 miles from the nearest dealer... I can most likely do some part replacement if it is minor. Thanks for your help, I am glad there are knowledgeable riders here willing to help.??????
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
Drive belt... Took off the housing an you can quickly see that the belt was a bit chewed up... Thanks for all you passers by that looked and didn't help... Found more info on YouTube... Yep can't add links for some reason... Why does this crappy forum even exist?
Thanks anyway.
 

·
Registered
Joined
·
860 Posts
Drive belt... Took off the housing an you can quickly see that the belt was a bit chewed up... Thanks for all you passers by that looked and didn't help... Found more info on YouTube... Yep can't add links for some reason... Why does this crappy forum even exist?
Thanks anyway.
Bye." A loud clunking noise" :p really isn't much to go on..................
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Drive belt... Took off the housing an you can quickly see that the belt was a bit chewed up... Thanks for all you passers by that looked and didn't help... Found more info on YouTube... Yep can't add links for some reason... Why does this crappy forum even exist?
Thanks anyway.
The initial description also stated the scenario...
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
I uncovered the possible issue and have overnighted a new belt drive and hope that takes care of the issue.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top