Polaris Ranger Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Ok I rebuilt my tranny deleting the turf mode, with a razor spool machine runs fantastic but I noticed now when I shift all the way down instead of it going into "P" like it used to I just get a -- on the dash and it won't hold like it used too I'm hoping that is due to the turf mode delete but just want to be sure, and also any good recommendations for an aftermarket parking brake, thank you
 

·
Super Moderator
Joined
·
2,404 Posts
The turf mode delete shouldn't affect the park operation.
The park plate is located inside the little housing behind where the shift lever shaft goes into the transmission.
I would check that out to make sure it is assembled correctly.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Anyone wouldn't happen to have a pic of how it was correctly put together would they??
 

·
Registered
Joined
·
68 Posts
Disconnect your shift cable at the bellcrank, Transaxle end.
Turn your key to the on position, move the bellcrank ( the aluminum flat piece that the cable hooks to) and see if it changes.
Do not try and shift it, we are just checking for slack.
Do this first before we move on.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #9
Thanks I'll check the slack, makes sense as I saw the motor/trans, didn't fit exactly like it used to so hopefully it just needs to have the cable adjusted, how does the park work?? Does it enage something, I noticed that even in gear the unit will still roll? But drives just fine
 

·
Registered
Joined
·
68 Posts
Thanks I'll check the slack, makes sense as I saw the motor/trans, didn't fit exactly like it used to so hopefully it just needs to have the cable adjusted, how does the park work?? Does it enage something, I noticed that even in gear the unit will still roll? But drives just fine
Your bellcrank rotates the shift drum, the shift drum moves the shift forks which move the engagement dogs to select your gear of choice.

Are you saying that in park your unit still rolls?

Not sure what you mean about the Trans not fitting like it used too.
You need to align the Trans so you will have proper clutch operation.

The parking plate that Rock mentioned earlier is not accessible through the sector cover.
This is not your issue, if you purchased a new Trans or case half, it is already pre installed.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
I took all the gears out installed a razor spool and then re-assembled the case.i was very careful and reinstalled it just like it was. But yes the unit will run in both high and low gear great clutxh alignment is good, but I can't get it to engage park won't even show it on the dash I just get -- sign and the unit will roll
 
1 - 11 of 11 Posts
Top