Polaris Ranger Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Ran my 2014 Ranger 570efi out of gas yesterday like an idiot. Went and got 2 gallons of fuel, put it in, still won’t start. It rolls over, but won’t fire. Tried putting a small amount of gas in spark plug hole, it fired, then cut off. I had to leave it in the woods and hike back to the truck. Any help would be appreciated!!!!!
 

·
Registered
Joined
·
244 Posts
Each time you turn the key to the on position it fires up the fuel pump (you can hear it). Try turning the key a few times before actually cranking it over. Maybe it just needs some fuel in the lines.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
I did try that, but I’m not sure I was hearing the pump. I’m going back out there after church with 2 more gallons of gas and a jumper box in case the battery is low from trying to start it so much!
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
I also heard you could unhook the negative battery cable, then re-hook , which will cause the pump to prime itself???? Not sure, but I will try it.
 

·
Registered
Joined
·
244 Posts
I’ve got the same year and model so looking forward to hearing your outcome. If it fired up with some fuel in the spark plug then likely a lack of fuel going through the lines which yes it could be the pump. I try to keep my tank as full as possible at all times to keep the fuel pump submerged which prevents it from overheating.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
I wouldn’t think it would overheat and be useless that quick. After the initial stall, it fired up a couple more times, then died quickly, just like running out would. Maybe vacuum locked????? Heading back out shortly to see if I can get it running.
 

·
Registered
Joined
·
45 Posts
I wouldn’t think it would overheat and be useless that quick. After the initial stall, it fired up a couple more times, then died quickly, just like running out would. Maybe vacuum locked????? Heading back out shortly to see if I can get it running.

I wonder if it has a filter that clogged when your tank ran dry..trash at the bottom? just a guess
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
Went back out and tried it again, no luck. Gonna have to get it towed out to see what the problem is. I unhooked the gas line at both ends, fuel came out. I blew on the line and it diessnt seem to be clogged. Guess I will put a new fuel pump in and hope that works! Any other suggestions? Fuses seem to be in good order as well.
 

·
Registered
Joined
·
45 Posts
Went back out and tried it again, no luck. Gonna have to get it towed out to see what the problem is. I unhooked the gas line at both ends, fuel came out. I blew on the line and it diessnt seem to be clogged. Guess I will put a new fuel pump in and hope that works! Any other suggestions? Fuses seem to be in good order as well.

"I unhooked the gas line at both ends", u could try and turn key on and see if pump even works? put the output hose in a bucket. maybe bench test that pump since u checked all fuses.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
I forgot to mention that I turned it over when I unhooked line from carb side, very little gas came out. Also, I tried turning key on and off a few times, didnt hear anything?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
I think it’s the pump too, gonna order one here shortly. Have to get it out of the woods first!!!!
 

·
Registered
Joined
·
191 Posts
When you run out of gas you risk burning up the pump. The pump is cooled and lubricated by fuel and trying to start or running low or empty just kills the pump. Replace the pump and never run low on fuel again. This applys to cars and trucks also.
 

·
Registered
Joined
·
207 Posts
Trash!

Most likely trash got sucked up into the fuel line. Check for clogged fuel filter or injectors.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #16
Update..... Replaced the fuel pump, it still won’t start!!!!!! Need some help here fellas!!!!!
 

·
Registered
Joined
·
223 Posts
Check fuel pressure and spark one of them must be missing. Does it even sound like it’s trying to fire. There should be some fuses for efi check them also.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #20
Fuses are all good.... I’ll check the pressure and spark.... Stay tuned! This is chapping me up!
 
1 - 20 of 24 Posts
Top