Polaris Ranger Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I just picked up a 2020 ranger 150 youth model for my kids. It started acting up with less than one hour on it, now it is 1.9 hours and no throttle response. I’m supposed to pick up my new 1000 XP and Friday and now I’m a little nervous having problems are ready with the small one. Looks like it’s error 84–2 which according to the manual I think is the vehicle speed sensor... Am I reading the manual correctly And has anyone had this issue?
23364
23365
 

·
Registered
Joined
·
4 Posts
If you find a solution to this please share. I just had the same code pop up yesterday. My factory warranty also expired 2 weeks ago conveniently
 

·
Registered
Joined
·
4 Posts
Ok thanks. Was it replaced under warranty, and if not, what did the dealer charge you if you dont mind me asking?
 

·
Registered
Joined
·
4 Posts
Thanks for the help. I just scheduled maintenance with my local dealer. From what I have been reading, this is a common issue with all models of rangers, and might not be the actual part that's the issue. I read another thread, something about flashing the ecu actually fixed this without any new parts. And that came from someone who replaced this part multiple times
 

·
Registered
Joined
·
21 Posts
Discussion Starter #10
Please let me know what they say, I’m still having an issue with the error that the brake is applied at the same time as The Gas. Thanks in advance!
 

·
Registered
Joined
·
4 Posts
I will keep you posted. They are booked full until next friday, so it will be a little bit
 
1 - 11 of 11 Posts
Top