Polaris Ranger Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
130 Hours and first shredded belt. Turns out I had a broken motor mount. One thing I did learn is I will now carry a drive clutch puller so I can remove the belt strings from behind it so as not to destroy the crank seal that is behind it.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
Yes I got it from the dealer but you can find them online. I was in a hurry to get back on the trail.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
Yes I did get a alingment tool. When you pull the driven clutch make sure to watch for the spacers behind it.
 

·
Registered
Joined
·
2,273 Posts
Is there any way you can get pictures of your tools and and make a new post telling what they are and where you purchased them. I am sure we all need a set.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
caglezxj I can get photos or I can post a link to were you can get them. There are photos there. The guy there is one of the best around for clutching questions. Just let me know if it is ok to post the link. Or if you would rather I just post photos.
 

·
Registered
Joined
·
2,273 Posts
Morganwoody said:
caglezxj I can get photos or I can post a link to were you can get them. There are photos there. The guy there is one of the best around for clutching questions. Just let me know if it is ok to post the link. Or if you would rather I just post photos.
pm me a copy of the link. I will see what all they offer. I don't want to step on the new sponsors toes, they might have something similar.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #10
Sent you a pm.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #12
One other thing I forgot to mention is the torque stop was not making contact with the motor. I adjusted it out until it just put a little pressure on the rubber end. I have mine back together but if you go to this web site http://parts.polarisind.com/Browse/Browse.asp
And look up your model and under engine mount you will find it. Mine is a 2006 700XP and it is item #13 part number 3021522 mount, torque stop. It looks like the 2008 is the same item number but the part number is 302154.
 
1 - 12 of 12 Posts
Top